Specification
   Price: USD 19.95
   Current version: 1.5
   Release date: Feb 09, 2009
   Compatbility: Windows Mobile devices





 
System Requirements
  • Internet enabled Windows mobile Pocket PC with GPS.
  • Requires WM5 and WM6 mobile devices.  Pocket PC 2003 or earlier devices are supported, but without certain functions. (snapshot and some types of export etc.) 
  • Requires Microsoft Compact Framework 2.0.  Can be downloaded from here or contact us for OTA (over-the-air) installation file.